Welcome to Wellcraft Boats Owners Forum

We are a boating forum for owners of Wellcraft Boats to enthusiastically discuss all aspects of Wellcraft Boat ownership. Whether you are looking for your first Wellcraft or currently own one, you are sure to feel at home on WellcraftBoatOwners.com

You are currently viewing our board as a guest which gives you limited access to view most discussions, articles and access our other FREE features. By joining our free community you will have access to searching the forum topics, post topics, communicate privately with other members (PM), respond to polls, upload your own photos and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

  • Global announcements
    Replies
    Views
    Last post

  • Latest news

View the latest post Very frustrating electrical issues with 85 gran sport.


Where to start. This season I've been having some intermittent electrical issues. 1st issue I had was the port side motor not starting. So what happens is I turn the key to start and the gauges don't do anything . What I also notice is the switches on the instrument panel don't work at this time.I will note that the blowers, both bilge pump and the starboard wiper work.. Checked connections I couldn't find anything out of the ordinary. I threw a meter on the fuse for port ignition and I have my 12v. I check the back of the ignition switch and I have 12v. Then I turn ignition key on to start and I loose my 12v. I disconnect the 3 purple wires and I get my 12v back. Now I know my gauges weren't working so I traced the one purple wire that fed the gauges and disconnect it, but hooked the other 2 purple wires back up. Boat would start and run . Then after a while the boat started doing the same thing all over again with the gauges disconnected. So I checked the dash switches for a short to ground. I see about 50 ohms. So I disconnected all the switches one at a time to see if I can isolate it. Nope couldn't find it. So then I checked all my grounds on that motor from the battery to the starter. It didn't fix the issue. I'm trying to find a wire diagram for the ignition. I'm not sure if this boat has a starter relay other than what's on the starter. Also I believe I have 2 issues here. I will also add that if I let the boat sit for a few hours it starts and acts fine. The switches on the dash even work. But whenever the port motor doesn't start the switches don't work either. Something ties them together. Very frustrated ! Oh, there's brand new battery on that motor also.

Views: 536  •  Comments: 6  •  Write comments [ Read all ]

View the latest post Total newbie here: What type of fuel to use?


I'm see conflicting advice on that. It's a fuel injected 7.4 in my 98 Excel 260.

Do I just get pump gas? Regular? Or is there something else?

Sadly, there's no owner's manual for this boat that I've been able to come up with.

12XX hours total, just tuned and oil/filter changed.

Image

Views: 322  •  Comments: 0  •  Write comments [ Read all ]

View the latest post Attachment(s) Sportsman 210 Gunnel anti slip inserts


Anybody know of a decent replacement for my anti slip grips on the gunnel's. If I even get close to them they leave black marks all over my clothes.

D47EECAF-1900-406E-9E06-A3657CFBC97E-3215-000001DE5A69AFD3.png

Views: 178  •  Comments: 1  •  Write comments [ Read all ]

View the latest post fuel tank vent


I have a 1998 210 Coastal. I have been having issues with phase separation of the ethanol fuel. I'm attempting to locate the vent for the fuel tank. On the port bow, there is a thru hull vent that I assumed was for the fuel tank. But, when I trace the vent hose from the tank it runs up under the fuel cap. Is this the only vent for the tank? What would the thru hull vent fitting be for? I bought an inline dryer cartridge to install on the vent hose to try and eliminate atmospheric moisture from being drawn into the tank. But, if the only vent is under the gas cap, would it not be sealed from the environment?

Views: 389  •  Comments: 2  •  Write comments [ Read all ]

View the latest post New guy reporting in...


Image

Picking this up this week. Just starting in the boating biz so thought we'd start small.

Have a lot of questions, so I thought I'd sign up here.

Views: 354  •  Comments: 4  •  Write comments [ Read all ]

View the latest post Attachment(s) New Member


Looking for a owners manual for a 35’ Californian .She has 2 Crusader’s that are gas

Views: 284  •  Comments: 3  •  Write comments

View the latest post Gas tank Pick up tube question


Hi All, I've been having some fuel starvation issues with my 270 Coastal. I went to pull and inspect the pickup tubes in the fuel tank, and low and behold the pickup tubes are welded into the tank.
Has anyone else seen this and if so, do you know if those pickup tubes have screens on them that could potentially get clogged?

Thanks
Jim

Views: 369  •  Comments: 4  •  Write comments [ Read all ]

View the latest post Part replacement.


Hey all. 2000 200SS with bow anchor storage compartment. Looking for compartment lid latch replacement. Any help greatly appreciated.

Views: 470  •  Comments: 2  •  Write comments

View the latest post Fuel Tank size , Fuel guage Calibration


I have a new to me 1992 wellcraft 20 Fish. Seller claims it had a 60 gallon fuel tank. I can not find any documentation confirming. It has a 2018 Suzuki 200 HP outboard , all controls steering and gauges installed with My gauge was reading on dead empty I put 26 gallows of fuel in and it started coming out of the vent overflow. The gauge now reads 2/3rds full. Supposedly the sending unit was changed with new gauges.

Can anyone help with Ideas how to fix. Thanks

Views: 258  •  Comments: 3  •  Write comments [ Read all ]

View the latest post New Memberf


Ahoy : I am new member, from Panama City , Fl. I have a new to me 1992 Wellcraft 20 Fish with a 2018 Suzuki 200 HP outboard.

Views: 249  •  Comments: 2  •  Write comments


  • The Sand Bar
    It's time to kick back with a cool one at the Sand Bar and talk about something else for a while! This forum is for all non-boating related discussions. NO POLITICS! The general forum rules apply, so don't co crazy :-)
    9 Topics
    32 Posts
    Last post July 4th
    by CptBill View the latest post
    Fri Jun 18, 2021 12:41 pm



  •  Newest members

  •  Top Posters

  •  Statistics
  • Totals
    Total posts 4596
    Total topics 1633
    Total Announcements: 0
    Total Stickies: 0
    Total Attachments: 887

    Topics per day: 1
    Posts per day: 2
    Users per day: 1
    Topics per user: 0
    Posts per user: 1
    Posts per topic: 3

    Total members 3986
    Our newest member IsmailAdam

  •  Who is online?
  • In total there are 13 users online :: 1 registered, 0 hidden and 12 guests

    Registered users: Bing [Bot]


  •  Sponsors

  •  Link to us
  • Please feel free to link to Wellcraft Boat Owners Forum. Use the following HTML:



  •  Clock