Welcome to Wellcraft Boats Owners Forum

We are a boating forum for owners of Wellcraft Boats to enthusiastically discuss all aspects of Wellcraft Boat ownership. Whether you are looking for your first Wellcraft or currently own one, you are sure to feel at home on WellcraftBoatOwners.com

You are currently viewing our board as a guest which gives you limited access to view most discussions, articles and access our other FREE features. By joining our free community you will have access to searching the forum topics, post topics, communicate privately with other members (PM), respond to polls, upload your own photos and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Live well not priming

Discussion of AC's, plumbing and sanitation related issues.

Topic author
thyme off
Posts: 7
Joined: Wed Sep 16, 2020 6:43 am
Vessel Info: 1990 Wellcraft 18 sport cc
2001 Yamaha 130 2-stroke
Karavan trailer
Been thanked: 4 times

Live well not priming

Postby thyme off » Tue Sep 22, 2020 8:00 am

I have a 1990 180 CC and can't get the live well to prime. Pump is running and there appears to be no leaks. Access hole under the transom is clear and there is not a valve that I can find. I believe that the pump supplies water to either the washdown hose bib near the live well or the well itself depending on weather the screw in the live well feed is open or closed. Any ideas?


LMK
Posts: 100
Joined: Thu Sep 05, 2019 11:30 am
Vessel Info: 2003 270 Coastal
Twin 225 Yamaha
Location: Darien, Ga.
Has thanked: 7 times
Been thanked: 19 times

Re: Live well not priming

Postby LMK » Tue Sep 22, 2020 11:07 am

There has to be a seacock somewhere to open it up. Has it worked before and now does not?

Topic author
thyme off
Posts: 7
Joined: Wed Sep 16, 2020 6:43 am
Vessel Info: 1990 Wellcraft 18 sport cc
2001 Yamaha 130 2-stroke
Karavan trailer
Been thanked: 4 times

Re: Live well not priming

Postby thyme off » Sun Sep 27, 2020 8:05 am

The tech at the repair yard was not able to find any kind of a valve. If there is one it is in a really tough place to get to which doesn;t make any sense. The well has not worked in the 3 years I have had the boat.

goodday
Posts: 224
Joined: Sun Aug 10, 2014 9:15 pm
Vessel Info: 1999 2600 Mart. 5.7 bravo3
Location: Wauseon Oh,
Has thanked: 25 times
Been thanked: 34 times

Re: Live well not priming

Postby goodday » Sun Sep 27, 2020 9:37 pm

Can you hose it up to see if pump actually working, motor maybe running but not pumping?

LMK
Posts: 100
Joined: Thu Sep 05, 2019 11:30 am
Vessel Info: 2003 270 Coastal
Twin 225 Yamaha
Location: Darien, Ga.
Has thanked: 7 times
Been thanked: 19 times

Re: Live well not priming

Postby LMK » Tue Sep 29, 2020 9:51 am

I would find a way to test the pump then I think I would replace the pump first if it is not working.

Topic author
thyme off
Posts: 7
Joined: Wed Sep 16, 2020 6:43 am
Vessel Info: 1990 Wellcraft 18 sport cc
2001 Yamaha 130 2-stroke
Karavan trailer
Been thanked: 4 times

Re: Live well not priming

Postby thyme off » Tue Oct 06, 2020 5:38 am

Thanks for the reply. Checking the pump is the only thing that makes sense.

mdowling73
Posts: 4
Joined: Wed Feb 17, 2021 2:06 pm
Vessel Info: 1990 Wellcraft 180 Sport with 150 HDPI Yamaha Motor

Re: Live well not priming

Postby mdowling73 » Wed Feb 17, 2021 2:49 pm

I have a 1990 180 Sport. I have a valve on the intake in the bilge - but it is a pain to get to for sure. I had to replace mine because it was seized up. I found all kids of debris inside from the previous owner pulling in junk through the inlet. Even if the pump turns out to be bad, you might check that inlet and make sure its clear.

Return to “AC/Heat, Plumbing & Sanitation”



Who is online

Users browsing this forum: No registered users and 1 guest