Welcome to Wellcraft Boats Owners Forum

We are a boating forum for owners of Wellcraft Boats to enthusiastically discuss all aspects of Wellcraft Boat ownership. Whether you are looking for your first Wellcraft or currently own one, you are sure to feel at home on WellcraftBoatOwners.com

You are currently viewing our board as a guest which gives you limited access to view most discussions, articles and access our other FREE features. By joining our free community you will have access to searching the forum topics, post topics, communicate privately with other members (PM), respond to polls, upload your own photos and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

High water Bilge

Anything related to the operation of your boat. Steering, Bilge Pumps, thru-hulls, bottom paint, etc.

Topic author
Wess
Posts: 9
Joined: Sat Apr 21, 2018 7:08 am
Vessel Info: 2002 Martinique 3300
Has thanked: 1 time
Been thanked: 1 time

High water Bilge

Postby Wess » Tue Aug 28, 2018 4:44 pm

I recently bought a 02 Martinique 3300. I had it out today and activated the High water bilge switch on the counsel, there was no water in the bilge, however, an alarm sounded. Is this normal or is something malfunctioning?


goodday
Posts: 156
Joined: Sun Aug 10, 2014 9:15 pm
Vessel Info: 1999 2600 Mart. 5.7 bravo3
Location: Wauseon Oh,
Has thanked: 5 times
Been thanked: 24 times

Re: High water Bilge

Postby goodday » Wed Sep 19, 2018 11:00 pm

Usually an alarm is oil, hot, outdr oil, maybe u have a high water alarm on it, did u try it again?, bet to just let u know it's running , per to main b pump failure

Topic author
Wess
Posts: 9
Joined: Sat Apr 21, 2018 7:08 am
Vessel Info: 2002 Martinique 3300
Has thanked: 1 time
Been thanked: 1 time

Re: High water Bilge

Postby Wess » Thu Mar 14, 2019 6:09 pm

Thanks for your reply, sorry I didn't reply sooner have been traveling. The alarm only comes on when I activate the high water bilge switch, like you said it probably lets me know its running.

Return to “General Repairs & Maintenance”



Who is online

Users browsing this forum: No registered users and 1 guest