Welcome to Wellcraft Boats Owners Forum

We are a boating forum for owners of Wellcraft Boats to enthusiastically discuss all aspects of Wellcraft Boat ownership. Whether you are looking for your first Wellcraft or currently own one, you are sure to feel at home on WellcraftBoatOwners.com

You are currently viewing our board as a guest which gives you limited access to view most discussions, articles and access our other FREE features. By joining our free community you will have access to searching the forum topics, post topics, communicate privately with other members (PM), respond to polls, upload your own photos and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

failure of fuel tank guages

Anything related to the operation of your boat. Steering, Bilge Pumps, thru-hulls, bottom paint, etc.

Topic author
egavasm
Posts: 1
Joined: Mon Jan 14, 2019 10:48 am
Vessel Info: 2007 Wellcraft Coastal 330

failure of fuel tank guages

Postby egavasm » Mon Jan 14, 2019 11:03 am

I have a 2007 Coastal 330 . Both of my fuel tanks have lost their readings. First one then a year later the other. Guages do not seem to be the problem so I am left to assume its senders or wiring. Has anyone had the same problem and found a solution. There does not seem to be any access to the sending units. I wondered if it was a common problem with the wellcrafts and if anyone has any trouble shooting experience to relay or other suggestions.

Return to “General Repairs & Maintenance”



Who is online

Users browsing this forum: No registered users and 1 guest