Welcome to Wellcraft Boats Owners Forum

We are a boating forum for owners of Wellcraft Boats to enthusiastically discuss all aspects of Wellcraft Boat ownership. Whether you are looking for your first Wellcraft or currently own one, you are sure to feel at home on WellcraftBoatOwners.com

You are currently viewing our board as a guest which gives you limited access to view most discussions, articles and access our other FREE features. By joining our free community you will have access to searching the forum topics, post topics, communicate privately with other members (PM), respond to polls, upload your own photos and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Top speed

Engine, transmission, I/O, OB and generator repair and maintenance discussion forum.

Topic author
masfel
Posts: 2
Joined: Sun Oct 06, 2019 1:54 pm
Vessel Info: Wellcraft Excalibur 26 m/y 2000 - Mercruiser 502

Top speed

Postby masfel » Sun Oct 06, 2019 2:07 pm

Hello! I write from Italy, just introduced myself in the other section.
I have a 2000 Excalibur 26 with Merc 502 engine. I bought the boat in a river place and it was without anti-fouling paint. In sea water i touched 59 mph at the begin. Now I must paint the hull and it seems that I lost 5 mph... Can anyone confirm that this is normal and the speed are good/normal?
Thanks a lot
Filippo

Return to “Engines, Transmissions & Drives”



Who is online

Users browsing this forum: No registered users and 0 guests